Categories
Code Snippets Tools

Xcode 4.2 and iOS5

I updated to the current version: xcode 4.2 with iOS 5, and needed to get old build(s) working for my oldest iPod which is a series 1 at iOS v3.1.3

All sorts of issues, while testing with the LottoDreams application here are my notes…

  • Missing features in the workspace – This may be caused simply because the features are hidden, and can be switched on from the View menu e.g. ViewShow Toolbar.
  • There may be issues with old (embedded) provisioning information. In this case, perhaps the easiest way to solve the problem is to edit the xcode project file directly to get rid of the original provisioning details. Simply edit the lottodreams.xcodeproj / project.pbxproj file with a text editor and remove all the lines which reference provisioningprofile
  • Set deployment SDK to the required one
  • Architecture for old iPods is armv6
  • Target…Build Phases tab Link Binary with Libraries – change required to optional